Failed to load the MailChimp PHP library. Please refer to the installation requirements.
The MailChimp PHP library is missing the required GuzzleHttp library. Please check the installation notes in README.txt.

Solution:

  • To remove this issue please choose the correct version of MailChimp module with corresponding to the Drupal version.
  • Download the library and paste it at sites/all/libraries
    Go to MailChimp PHP library
    Please verify your versions. Go to your module and sites\all\modules\**\mailchimp\mailchimp.module then see the code which library to download.
    hook_libraries_info() let you use an external library in your module, you need to make it known first and can be done by implementing this function as mailchimp_libraries_info()
  • Folder structure will look like below images (may differ in your case, mine drupal version is 7.34):
  • Clear the cache
    Home » Administration » Configuration » Development » Performance

Hope this will solve your problem. If not let us know and we will dig more

 

Overview of library creator:
============================================
A PHP 5.2+ API client for [v2 of the MailChimp API](http://apidocs.mailchimp.com/api/2.0/). Please note that we generate this client/wrapper, so while we’re happy to look at any pull requests, ultimately we can’t technically accept them. We will, however comment on any additions or changes made due to them before closing them.
###Usage
This can be installed via [Composer](http://getcomposer.org/) and our [packagist package](https://packagist.org/packages/mailchimp/mailchimp).

A basic example app to help kickstart you which – will also automatically install this package – is over in a public [github](https://github.com/mailchimp/mcapi2-php-examples) repo.

===============================================

Thanks
Rupak

LEAVE A REPLY

Please enter your comment!
Please enter your name here