Drupal error white user page, the design is showing in the index page, database contents are not showing in eCommerce website

    While working with one of the eCommerce websites I came up with a drupal error that shows a blank white page when I try to go to admin or /user but design and CSS are showing, only database contents are not showing.

    I searched many things but not able to find a solution and solve them simply by clearing caches. I thought to clear the cache but I am not able to log in and not able to go to link /admin/config/development/performance.

    Thus I found following code to flush all caches. I kept following code in \sites\all\themes\theme_name\templates\page.tpl.php and hard refresh by performing crtl+F5

    <?php
      require_once DRUPAL_ROOT . '/includes/bootstrap.inc';
      drupal_bootstrap(DRUPAL_BOOTSTRAP_FULL);
      drupal_flush_all_caches();
    ?>

    Then, boooom my pages are back with contents, now started working normally 🙂

    Thanks for the drupal_flush_all_caches method 🙂

    Fatal error: Uncaught Error: Call to undefined function _system_default_theme_features() in D:\xampp7\htdocs\..\includes\theme.inc on line 1430( ! ) Error: Call to undefined function _system_default_theme_features() in D:\xampp7\htdocs\..\includes\theme.inc on line 1430Call Stack#TimeMemoryFunctionLocation10.08306089760_drupal_exception_handler( )…\bootstrap.inc:020.08306090232_drupal_log_error( )…\bootstrap.inc:236530.08306091904theme( )…\errors.inc:24540.08606224864template_preprocess_maintenance_page( )…\theme.inc:112550.08606224896theme_get_setting( )…\theme.inc:2796

    Add following line to D:\xampp\apache\conf\httpd.conf if your website keeps on showing “Connection Errors”

    <IfModule mpm_winnt_module>
       ThreadStackSize 8388608
    </IfModule>

    LEAVE A REPLY

    Please enter your comment!
    Please enter your name here